HEX
Server: Apache/2.4.46 (Win64) OpenSSL/1.1.1j PHP/8.4.25
System: Windows NT DESKTOP-4TAV2RJ 10.0 build 19045 (Windows 10) AMD64
User: fred (0)
PHP: 8.4.25
Disabled: NONE
Upload Files
File: C:/Windows/System32/zh-TW/ESENT.dll.mui
MZ����@���	�!�L�!This program cannot be run in DOS mode.

$5�<�q�R�q�R�q�R�e���p�R�e�P�p�R�Richq�R�PEL�!

0�@ |8.rdata�@@.rsrc @@��c
T88��c$��8.rdata8x.rdata$zzzdbg �.rsrc$01� �.rsrc$02 ��������T�僞bI���[����c��(�@�X�p��������� ���!<��'��MUI���Ė�m �����u��g����I7�[�,S�����MUIzh-TWdl���p��$	��8�������,0$EO�������<.�bX�@���@���� (����X��� ���d��	�	�����%1 (%2) %3%4
一般
資料庫頁面快取
記錄/修復
空間管理
$資料表/列/索引定義
記錄控制
執行
資料庫修復
資料庫轉換
線上磁碟重組
系統參數設定
資料庫損壞
資料庫零位調整
交易管理員
資源失敗模擬
陰影複製
失敗項目
System Device
<EOL>
<%1 (%2) %3 資料庫引擎 %4.%5.%6.%7 已啟動。
0%1 (%2) %3 資料庫引擎已停止。
P%1 (%2) %3資料庫引擎 (%5.%6.%7.%8) 正在啟動新的例項 (%4)。
p%1 (%2) %3資料庫引擎停止了例項 (%4)。
%n
%n不正常關機: %6
%n
%n內部計時順序: %5
l%1 (%2) %3資料庫引擎停止了帶有錯誤 (%5) 的例項 (%4)。
%n
%n內部計時順序: %6
�%1 (%2) %3The database engine started a new instance (%4). (Time=%5 seconds)
%n
%nAdditional Data:%n
%7
%n
%nInternal Timing Sequence: %6
d%1 (%2) %3已嘗試將參數 %4 設至 %5,但被登錄設定 (位於 %7) 覆寫為 %6。
h%1 (%2) %3從登錄設定 (位於 %7) 讀取參數 %4,但 ESE 引擎拒絕值 %5,錯誤 %6。
�%1 (%2) %3特定的 ESE 組態存放區已鎖定為禁止讀取狀態,請清除 %1 登錄值來啟用 ESE 以繼續,並且使用組態存放區。
<%1 (%2) %3資料庫正在啟動一個完整備份。
<%1 (%2) %3資料庫正在啟動一個增量備份。
8%1 (%2) %3資料庫引擎已完成備份過程。
D%1 (%2) %3由於錯誤 %4,資料庫引擎停止了備份。
�%1 (%2) %3資料庫引擎正在從備份還原。還原將會開始重放資料夾 %4 中的記錄檔案,並繼續向前回捲資料夾 %5 中的記錄檔案。
4%1 (%2) %3資料庫引擎停止了還原。
|%1 (%2) %3資料庫 %4 無法進行增量備份。您必須先執行一次完整備份,才能進行增量備份。
d%1 (%2) %3資料庫引擎停止備份, 因為用戶端停止或與用戶端連接失敗。
4%1 (%2) %3正在啟動一個完整備份。
4%1 (%2) %3正在啟動一個增量備份。
8%1 (%2) %3正在啟動一個陰影複製備份。
4%1 (%2) %3備份程序已成功地完成。
4%1 (%2) %3備份因為錯誤 %4 而停止。
T%1 (%2) %3備份停止, 由於用戶端停止或與用戶端連接失敗。
H%1 (%2) %3從 '%4' 到 '%5' 偵測到資料庫位置的變更。
d%1 (%2) %3在備份資料庫期間發生錯誤 (%4) (檔案 %5)。資料庫將無法還原。
H%1 (%2) %3在複製或備份檔案 %5 期間發生錯誤 (%4)。
T%1 (%2) %3利用備份資訊更新資料庫標題期間發生錯誤 (%4)。
L%1 (%2) %3正在開始檔案 %4 的複製或備份 (大小為 %5)。
<%1 (%2) %3正在結束檔案 %4 的複製或備份。
�%1 (%2) %3正在結束檔案 %4 的備份。並非檔案中的所有資料都已經被讀取 (已經讀取 %5 / %6 的位元組)。
H%1 (%2) %3正在開始記錄檔案的備份 (範圍 %4 - %5)。
8%1 (%2) %3正在刪除記錄檔案 %4 至 %5。 
4%1 (%2) %3無法截斷任何記錄檔案。
P%1 (%2) %3備份已提早停止了 (可能是因為例項已終止)。
X%1 (%2) %3在我們嘗試要截斷的記錄範圍內找不到 %4 記錄檔。 
t%1 (%2) %3正在啟動內部副本 (供植入或分析之用)。傳輸方法則使用串流 ESE 備份 API。
\%1 (%2) %3內部資料庫複製 (供植入或分析之用) 程序已順利完成。 
\%1 (%2) %3內部資料庫複製 (供植入或分析之用) 已停止。錯誤: %4。
�%1 (%2) %3因為用戶端停止內部資料庫複製或與用戶端的連線失敗,所以內部複製 (供植入或分析之用) 停止。
�%1 (%2) %3正在結束檔案 %4 的內部複製 (供植入或分析之用)。尚未完全讀取檔案中的所有資料 (已讀取 %5 個位元組,共 %6 個位元組)。
x%1 (%2) %3內部資料庫複製 (供植入或分析之用) 已永久停止 (可能是因為例項正在終止)。
<%1 (%2) %3資料庫引擎正在起始修復步驟。
�%1 (%2) %3The database engine has finished replaying logfile %4.
%n
%nProcessing Stats: %5
%nLog record of type '%6' was seen most frequently (%7 times)
@%1 (%2) %3資料庫引擎已成功完成修復步驟。
4%1 (%2) %3出現資料庫引擎錯誤 %4。
H%1 (%2) %3資料庫引擎已成功地完成重新執行步驟。
�%1 (%2) %3The database engine created a new database (%4, %5). (Time=%6 seconds)
%n
%nAdditional Data: %9
%n
%nInternal Timing Sequence: %7
�%1 (%2) %3The database engine attached a database (%4, %5). (Time=%6 seconds)
%n
%nSaved Cache: %8
%nAdditional Data: %9
%n
%nInternal Timing Sequence: %7
�%1 (%2) %3The database engine detached a database (%4, %5). (Time=%6 seconds)
%n
%nRevived Cache: %8
%nAdditional Data: %9
%n
%nInternal Timing Sequence: %7
|%1 (%2) %3資料庫引擎在復原期間已於記錄位置 %5 為附加資料夾 %4 發出回撥。回撥傳回 %6。
|%1 (%2) %3資料庫引擎在復原期間已於記錄位置 %5 為卸離資料夾 %4 發出回撥。回撥傳回 %6。
�%1 (%2) %3The database [%4] format version is being held back to %6 due to application parameter setting of %5. Current default engine version: %7.
|%1 (%2) %3The database [%4] version was upgraded from %5 to %6. Current engine format version parameter setting: %7
T%1 (%2) %3資料庫 [%4] 版本 %5 高於引擎 %6 支援的最大版本。
�%1 (%2) %3The database [%4] version %5 is higher than the maximum version configured by the application %6. Current engine format version parameter setting: %7
�%1 (%2) %3The database [%4] has completed incremental reseed page patching operations for %5 pages.
%n
%nDetails:
%nRange of Patching: %6
%nTiming: %7
|%1 (%2) %3Replay of a %4 for database "%5" at log position %6 was deferred due to %7.  Additional information:  %8
�%1 (%2) %3從檔案 "%4" 的位移 %5 (資料庫分頁 %9) 取得 %6 位元組的驗證失敗。位元 %8 已損毀而且已修正,但是分頁驗證因錯誤 %7 而失敗。此問題有可能是因為硬體故障所造成,而且可能持續發生。像這類的暫時性失敗有可能是包含此檔案的儲存子系統中災難性失敗的前兆。請連絡硬體廠商以獲得診斷問題的進一步協助。
�%1 (%2) %3從檔案 "%4" 的位移 %5 (資料庫分頁 %8) 取得 %6 位元組的驗證失敗。位元 %7 已損毀而且已修正。此問題有可能是因為硬體故障所造成,而且可能持續發生。像這類的暫時性失敗有可能是包含此檔案的儲存子系統中災難性失敗的前兆。請連絡硬體廠商以獲得診斷問題的進一步協助。
�%1 (%2) %3出現同步重疊讀取頁面時間錯誤 %4。如果問題持續出現,請從前一次備份中還原資料庫。
D%1 (%2) %3出現同步重疊寫入頁面發佈錯誤 %4。
<%1 (%2) %3出現同步重疊寫入頁面錯誤 %4。
H%1 (%2) %3出現同步重疊修補檔案寫入頁面錯誤 %4。
h%1 (%2) %3出現同步讀取頁面檢驗和錯誤 %4。請從前一次備份中還原資料庫。
�%1 (%2) %3出現預讀取頁面檢驗和錯誤 %4。如果此錯誤持續出現,請從前一次備份中還原資料庫。
�%1 (%2) %3直接讀取發現損壞的頁面 %4 錯誤 %5。如果此錯誤持續出現,請從前一次備份中還原資料庫。
D%1 (%2) %3出現緩衝區 I/O ,執行緒終止錯誤 %4。
<%1 (%2) %3無法寫入記錄檔案 %4。錯誤 %5。
D%1 (%2) %3無法寫入記錄檔案 %4 標題。錯誤 %5。
<%1 (%2) %3無法讀取記錄檔案 %4。錯誤 %5。
�%1 (%2) %3記錄檔案 %4 的記錄版本標記與資料庫引擎版本標記不相符。記錄檔案在資料庫中的版本可能不正確。
H%1 (%2) %3無法讀取記錄檔案 %4 的標題。錯誤 %5。
�%1 (%2) %3無法建立新的記錄檔案,原因是資料庫無法寫入記錄磁碟機。磁碟機可能為唯讀、用完磁碟空間、設定錯誤或損壞。錯誤 %4。
T%1 (%2) %3在清除記錄檔案 %4 時無法寫入 0 區段。錯誤 %5。
T%1 (%2) %3在清除記錄檔案 %4 時無法寫入 1 區段。錯誤 %5。
T%1 (%2) %3在清除記錄檔案 %4 時無法寫入 2 區段。錯誤 %5。
T%1 (%2) %3在清除記錄檔案 %4 時無法寫入 3 區段。錯誤 %5。
T%1 (%2) %3在開啟一個新建立的記錄檔案 %4 時出現錯誤 %5。
�%1 (%2) %3Unable to read page %5 of database %4.%n
Additional information:%n
%tError code: %6%n
%tLog position: %7%n
%tPage timestamp: %8%n
�%1 (%2) %3無法讀取資料庫 %4 的標題。錯誤 %5。資料庫可能已被移動,因此將可能不會出現在記錄所預期的位置。
d%1 (%2) %3沒有還原在 %5 建立的資料庫 %4。已在 %5 建立還原的資料庫。
<%1 (%2) %3沒有還原在 %5 建立的資料庫 %4。
D%1 (%2) %3資料庫引擎發現了一個錯誤的頁面。
<%1 (%2) %3資料庫磁碟已滿。在刪除記錄檔案以還原磁碟空間時,如果資料庫檔案並非處於正常關記狀態,有可能會使資料庫無法啟動。只有在資料庫檔案是處於正常關記狀態,編號的記錄檔案才可以移動,但不可以刪除。請勿移動 %4。
H%1 (%2) %3資料庫簽名與資料庫 %4 的記錄簽名不符。
P%1 (%2) %3資料庫引擎無法找到名為 %4 的檔案或資料夾。
D%1 (%2) %3資料庫引擎無法存取名為 %4 的檔案。
h%1 (%2) %3由於記錄磁碟上的可用磁碟空間太少,資料庫引擎拒絕更新操作。
H%1 (%2) %3資料庫引擎記錄磁碟已滿。在刪除記錄檔案以還原磁碟空間時,如果資料庫檔案並非處於正常關記狀態,有可能會使資料庫無法啟動。只有在資料庫檔案是處於正常關記狀態,編號的記錄檔案才可以移動,但不可以刪除。請勿移動 %4。
<%1 (%2) %3資料庫 %4 及其修補檔案不相符。
\%1 (%2) %3起始的還原記錄檔案 %4 太高。應該從記錄檔案 %5 開始。
X%1 (%2) %3終止還原記錄檔案 %4 太低。應該在記錄檔案 %5 終止。
H%1 (%2) %3還原記錄檔案 %4 沒有正確的記錄簽名。
x%1 (%2) %3還原記錄檔案 %4 的時間標記與在記錄檔案中記錄的前一個時間標記不相符。
0%1 (%2) %3缺少還原記錄檔案 %4。
�%1 (%2) %3記錄檔案 %4 的簽名與其他記錄檔案不相符。必須所有簽名都相符後修復才能成功。記錄檔案 %5 到 %6 已經被刪除。
�%1 (%2) %3在記錄檔案 %4 和它前一個記錄檔案之間的順序編號中出現間隔。記錄檔案 %5 到 0x%6 已經被刪除,使得該修復能夠完成。
@%1 (%2) %3備份資料庫 %4 必須是 4 KB 的倍數。
H%1 (%2) %3無法寫入檔案 %4 的陰影標題。錯誤 %5。
�%1 (%2) %3記錄檔 %4 已損壞、無效或無法存取 (錯誤 %5) 且無法使用。如果復原時需要此記錄檔,則必須提供良好的記錄檔副本,才能成功完成復原。
�%1 (%2) %3在輸入輸出期間,資料庫 %4 上出現檔案系統錯誤 %5。如果這個錯誤持續出現,則資料庫檔案可能已經損壞,而需要從先前的備份中還原。
p%1 (%2) %3IO 大小與資料庫 %4 不相符。在返回的大小為 %6 時預期的 IO 大小為 %5。
H%1 (%2) %3File system error %5 during IO or flush on logfile %4.
t%1 (%2) %3IO 大小與記錄檔案 %4 不相符。在返回的大小為 %6 時預期的 IO 大小為 %5。
�%1 (%2) %3資料庫 %4 已到達資料庫的最大容量 %5 MB。如果資料庫無法重新啟動,可以執行離線磁碟重組以減少資料庫的大小。
�%1 (%2) %3在還原記錄檔案 %4 (%5,%6) 時,資料庫修復異常停止。此點之後的記錄檔案可能無法辨識並且不會被處理。
�%1 (%2) %3A bad page link (error %4) has been detected in a B-Tree (ObjectId: %5, PgnoRoot: %6) of database %7 (%8 => %9, %10).%n
Tag: %11%n
Fatal: %12%n
X%1 (%2) %3在資料庫 %5 (%6,%7) 的資料表 %4 中偵測出資料不一致。
@%1 (%2) %3偵測到串流資料指派不一致 (%4,%5)。
�%1 (%2) %3在記錄檔案序列中偵測到間隔。缺少記錄檔案 %4。除此之外的其他記錄檔案可能也會需要。如果缺少的記錄檔案並未還原的話,此訊息可能會重新出現。
T%1 (%2) %3在刷新記錄檔案 %4 時,無法寫入第 4 區。錯誤 %5。
�%1 (%2) %3資料庫 %4 需要記錄檔案 %5-%6 才能成功修復。修復只能找出開始於 %7 的記錄檔案。
�%1 (%2) %3資料庫 %4 需要記錄檔 %5-%6 (%8 - %9) 才能成功修復。修復只能找出最多 %7 (%10) 個記錄檔。
H%1 (%2) %3資料庫修復/還原失敗,發生意外錯誤 %4。
D%1 (%2) %3當開啟日誌檔案 %4 時,錯誤%5 發生。
p%1 (%2) %3檔案 %4 的主標頭頁面已損壞。會使用陰影標頭頁面 (%5 位元組) 來代替。
�%1 (%2) %3現有記錄檔 %4 的記錄簽名與備份集中的記錄檔案不符合。除非所有簽名完全符合,否則記錄檔案重放將無法成功。
�%1 (%2) %3記錄檔案 %4 和 %5 不是以有效的順序出現。如果在可用記錄檔案的順序中有間隙,記錄檔案重放將無法成功。
8%1 (%2) %3檔案 %4 遺失而且無法備份。
�%1 (%2) %3當從備份記錄檔案 %4 進行恢復時偵測到 torn-write。失敗核對總和的記錄位於位置 %5。這個記錄檔案已經損壞而且無法使用。
�%1 (%2) %3當從記錄檔案 %4 進行硬修復時檢測到  torn-write。失敗核對總和的記錄位於位置 %5。這個記錄檔案已經損壞而且無法使用。
�%1 (%2) %3當從記錄檔案 %4 進行軟修復時偵測到 torn-write。失敗核對總和的記錄位於位置 %5。記錄檔案的損壞將可修復,而修復將會繼續進行。
�%1 (%2) %3當從備份記錄檔案 %4 進行恢復時檢測到訛誤。失敗核對總和的記錄位於位置 %5。與記錄檔案填充模式不相符的資料首先出現在磁區 %6。這個記錄檔案已經損壞而且無法使用。
�%1 (%2) %3當從備份記錄檔案 %4 進行硬修復時檢測到訛誤。失敗核對總和的記錄位於位置 %5。
與記錄檔案填充模式不相符的資料首先出現在磁區 %6。這個記錄檔案已經損壞而且無法使用。
�%1 (%2) %3當從備份記錄檔案 %4 進行軟修復時檢測到訛誤。失敗核對總和的記錄位於位置 %5。
與記錄檔案填充模式不相符的資料首先出現在磁區 %6。這個記錄檔案已經損壞而且無法使用。
h%1 (%2) %3使用記錄檔案 %4 中的陰影磁區複製來修補無效的核對總和記錄。
P%1 (%2) %3資料庫 %6: 資料表 %5 的索引 %4 已經損壞 (%7)。
P%1 (%2) %3在更新記錄檔案 %4 時無法寫入區段 5。錯誤 %5。
T%1 (%2) %3資料庫 %4 已部份附加。 附件階段: %5。錯誤: %6。
�%1 (%2) %3無法回復資料庫 %5 中的作業 #%4。錯誤: %6。未來所有資料庫更新的動作將會被拒絕。
t%1 (%2) %3檔案 %4 的陰影標頭頁面已經損壞。會使用主標頭頁面 (%5 位元組) 來代替。
`%1 (%2) %3資料庫 %4 已部份分離。在更新資料庫標題時發生錯誤 %5。
�%1 (%2) %3從檔案 "%4" 的位移 %5 處 (資料庫頁面 %10) 讀取 %6 個位元組的資料庫頁面驗證失敗,原因是頁面總和檢查不相符。儲存的總和檢查碼為 %8 而運算所得的總和檢查碼為 %9。讀取作業將會失敗並出現錯誤 %7。如果此情況持續出現,則請從前一個備份還原資料庫。這個問題很有可能是因為硬體錯誤。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3從檔案 "%4" 讀取的資料庫頁面 (位移 %5;%6 個位元組) 驗證失敗,原因是頁數不相符。預期的頁數為 %8 而儲存的頁數為 %9。 讀取作業將會失敗並出現錯誤 %7。 如果此情況持續出現,則請從前一個備份還原資料庫。這個問題很有可能是因為硬體錯誤。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3從檔案 "%4" 的位移 %5 處 (資料庫頁面 %8) 讀取 %6 個位元組的資料庫頁面驗證失敗,原因是它並未包含頁面資料。讀取作業將會失敗並出現錯誤 %7。如果此情況持續出現,則請從前一個備份還原資料庫。這個問題很有可能是因為硬體有瑕疵。請連絡您的硬體製造商已取得更多的協助來診斷此問題。
<%1 (%2) %3從檔案 "%4" 讀取的記錄範圍 (位移 %5; %6 位元組) 的確認失敗,原因是範圍總和檢查不相符。預期的總和檢查為 %8 而實際的總和檢查為 %9。讀取作業將會失敗並出現錯誤 %7。如果此情況持續出現,則請從前一個備份還原資料庫。
@%1 (%2) %3從檔案 "%4" 讀取的串流頁面 (位移 %5; %6 位元組) 的確認失敗,原因是頁面總和檢查不相符。 預期的總和檢查為 %8 而實際的總和檢查為 %9。 讀取作業將會失敗並出現錯誤 %7。 如果此情況持續出現,則請從前一個備份還原資料庫。
<%1 (%2) %3從檔案 "%4" 讀取的修補頁面 (位移 %5; %6 位元組) 的確認失敗,原因是頁面總和檢查不相符。 預期的總和檢查為 %8 而實際的總和檢查為 %9。 讀取作業將會失敗並出現錯誤 %7。 如果這個情況持續出現,請使用先前的備份集還原。
$%1 (%2) %3從檔案 "%4" 讀取的修補頁面 (位移 %5; %6 位元組) 的確認失敗,原因是頁數不相符。 預期的頁數為 %8 而實際的頁數為 %9。 讀取作業將會失敗並出現錯誤 %7。如果這個情況持續出現,請使用先前的備份集還原。
%1 (%2) %3在 %10 秒後嘗試從檔案 "%4" (位移 %5; %6 位元組) 讀取失敗,並出現系統錯誤 %8: "%9"。 讀取作業將會失敗並出現錯誤 %7。如果這個錯誤持續出現,則檔案可能已經損壞而需要從先前的備份還原。
%1 (%2) %3在 %10 秒後嘗試寫入檔案 "%4" (位移 %5; %6 位元組) 失敗,並出現系統錯誤 %8: "%9"。 寫入作業將會失敗並出現錯誤 %7。如果這個錯誤持續出現,則檔案可能已經損壞而需要從先前的備份還原。
�%1 (%2) %3嘗試建立資料夾 "%4" 失敗並出現系統錯誤 %6: "%7"。 建立資料夾作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試移除資料夾 "%4" 失敗並出現系統錯誤 %6: "%7"。 移除資料夾作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試刪除資料夾 "%4" 失敗並出現系統錯誤 %6: "%7"。 刪除資料夾作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試移動檔案 "%4" 至 "%5" 失敗並出現系統錯誤 %7: "%8"。 移動檔案作業將會失敗並出現錯誤 %6。
�%1 (%2) %3嘗試複製檔案 "%4" 至 "%5" 失敗並出現系統錯誤 %7: "%8"。 複製檔案作業將會失敗並出現錯誤%6。
�%1 (%2) %3嘗試建立檔案 "%4" 失敗並出現系統錯誤 %6: "%7"。 建立檔案作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試開啟檔案 "%4" 供唯讀存取失敗並出現系統錯誤 %6: "%7"。 開啟檔案作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試開啟檔案 "%4" 供讀 / 寫存取失敗並出現系統錯誤 %6: "%7"。 開啟檔案作業將會失敗並出現錯誤 %5。
�%1 (%2) %3嘗試決定在包含 "%5" 的磁碟區 "%4" 中,最小的輸入/輸出區塊大小失敗並出現系統錯誤 %7: "%8"。 作業將會失敗並出現錯誤 %6。
�%1 (%2) %3 "%4" 中的記錄檔案序列由於發生嚴重錯誤而停止。 使用此記錄檔案序列的資料庫將無法做進一步的更新。請修正問題然後重新啟動或從備份還原。
L%1 (%2) %3在最後成功的作業之前,檔案 "%4" 中的讀取作業 (位移 %5; %6 位元組) 在 %8 秒的間隔內失敗了 %7 次。有關這些失敗的特定資訊先前已經有報告記錄。類似這些短暫失敗的情況有可能是在包含這個檔案的儲存子系統中會發生嚴重失敗的前兆。
�%1 (%2) %3資料庫還原失敗並出現錯誤 %4,原因是遇到已不存在的資料庫參照 '%5'。資料庫在移除前將不會進入正常關記狀態 (或者有可能被移動或重新命名)。資料庫引擎將不允許還原以完成此例項,直到重新安裝遺失的資料庫為止。如果資料庫的確無法使用而且不再需要,如需修復這個錯誤的程序,請參閱 Microsoft Knowledge Base 或是遵循此訊息下方的 [其他資訊] 連結。
�%1 (%2) %3在 '%5' 上的資料庫修復失敗並出現錯誤 %4。資料庫目前的狀態與記錄檔案中預期此資料庫的第一參照不同。有可能是這個資料庫的檔案複本已經還原,但是並非自建立檔案複本以來所有的記錄檔案目前都可以使用。如需修復這個錯誤的程序,請參閱 Microsoft Knowledge Base 或是遵循此訊息下方的 [其他資訊] 連結。
�%1 (%2) %3資料庫 %4 需要將記錄檔案 %5 建立於 %6 才能成功地修復。修復發現記錄檔案建立於 %7。
�%1 (%2) %3從 %4 的表頭所提供的資訊來看,該檔案不是資料庫檔案。檔案表頭可能已經損壞。
�%1 (%2) %3記錄序號中存在有間隔,最近使用的記錄檔案有 %4 代。記錄檔案 %5 至 %6 已經刪除,因此該復原能夠完成。
�%1 (%2) %3記錄序號中存在有間隔,最近使用的記錄檔案有 %4 代。記錄檔案 %5 ( %6 代) 已經刪除,因此該復原能夠完成。
�%1 (%2) %3資料庫引擎遺失一頁壞的資料。強烈建議您執行資料庫的應用程式等級整合性檢查,以確保應用程式等級資料的整合性。
@%1 (%2) %3資料庫引擎修復了一個頁面連結。
�%1 (%2) %3資料庫引擎遺失了一個記錄中的一欄或多欄壞的資料。強烈建議您執行資料庫的應用程式等級整合性檢查,以確保應用程式等級資料的整合性。
�%1 (%2) %3資料庫引擎遺失了一個壞的資料記錄。強烈建議您執行資料庫的應用程式等級整合性檢查,以確保應用程式等級資料的整合性。
�%1 (%2) %3資料庫引擎遺失了一個稱為 %4 的資料表。強烈建議您執行資料庫的應用程式等級整合性檢查,以確保應用程式等級資料的整合性。
t%1 (%2) %3嘗試開啟壓縮檔案 "%4" 進行讀 / 寫存取的動作失敗,原因是它無法轉換成一般的檔案。開啟檔案作業將會失敗並出現錯誤 %5。在未來若要避免這種錯誤,您可以手動地將檔案解壓縮並將包含資料夾的壓縮狀態變更為未壓縮。目前尚不支援檔案為壓縮狀態時寫入此檔案。
�%1 (%2) %3嘗試決定在包含 "%5" 的磁碟區 "%4" 中,可用/總計空間總數的動作失敗並出現系統錯誤 %7: "%8"。作業將會失敗並出現錯誤 %6。
%1 (%2) %3要求從檔案 "%4" (位移 %5; %6 位元組) 讀取已成功,但是作業系統花了異常久的時間 (%7 秒) 來完成此服務。這個問題很有可能是因為硬體有瑕疵。請連絡您的硬體製造商已取得更多的協助來診斷此問題。
%1 (%2) %3要求寫入到檔案 "%4" (位移 %5; %6 位元組) 已成功,但是作業系統花了異常久的時間 (%7 秒) 來完成此服務。這個問題很有可能是因為硬體有瑕疵。請連絡您的硬體製造商已取得更多的協助來診斷此問題。
�%1 (%2) %3要求從檔案 "%4" (位移 %5; %6 位元組) 讀取已成功,但是作業系統花了異常久的時間 (%7 秒) 來完成此服務。此外,%8 個其他對此檔案的 I/O 要求也都花了異常久的時間來完成服務,因為上一次有關此問題的訊息是公佈於 %9 秒以前。這個問題很有可能是因為硬體有瑕疵。請連絡您的硬體製造商已取得更多的協助來診斷此問題。
�%1 (%2) %3要求寫入到檔案 "%4" (位移 %5; %6 位元組) 已成功,但是作業系統花了異常久的時間 (%7 秒) 來完成此服務。此外,%8 個其他對此檔案的 I/O 要求也都花了異常久的時間來完成服務,因為上一次有關此問題的訊息是公佈於 %9 秒以前。這個問題很有可能是因為硬體有瑕疵。請連絡您的硬體製造商已取得更多的協助來診斷此問題。
�%1 (%2) %3系統已服務 %4 個工作,但是它花費了相當長的時間 (%5 秒鐘用以發送,%6 秒鐘用以執行)。

%1 (%2) %3系統已服務 %4 個工作,但是它花費了相當長的時間 (%5 秒鐘用以發送,%6 秒鐘用以執行)。此外,自從 %8 秒之前張貼關於此問題的最後一個訊息之後,服務 %7 個其他 %4 工作也花費了相當長的時間。

<%1 (%2) %3此執行個體的記錄順序號碼已幾乎完全用盡。目前的記錄產生是 %4,正在逐漸接近 %5 的記錄產生上限,還剩下 %6 個記錄產生可以使用。若要從記錄產生 1 開始重新編號,必須關閉執行個體並刪除所有的記錄檔。備份將會失效。
�%1 (%2) %3資料庫 %4: 分頁 %5 驗證失敗,因為清除順序的依存性不相符。這個分頁應該在分頁 %6 之前清除,但是卻先清除後者的分頁。修復/還原將因錯誤 %7 而失敗。如果這個狀況持續發生,則請從之前的備份還原資料庫。這個問題有可能是因為硬體故障,而在過去的某個時間於這些分頁的一頁或兩頁上「遺失」一或多個清除。請連絡硬體廠商以獲得診斷問題的進一步協助。
�%1 (%2) %3Database %4: Page %5 failed verification due to a timestamp mismatch at log position %10 (currently replaying log position %12).  The 'before' timestamp persisted to the log record was %6 but the actual timestamp on the page was %7.  The 'after' update timestamp %9 that would have updated the on-page timestamp.  Recovery/restore will fail with error %8.  If this condition persists then please restore the database from a previous backup. This problem is likely due to faulty hardware "losing" one or more flushes on this page some time in the past. Please contact your hardware vendor for further assistance diagnosing the problem.
%nAdditional information:
%n%tWithin initial required range: %11
%n%tTotal number of pages affected: %13
�%1 (%2) %3資料庫因錯誤 %4 而修復失敗,因為它發生資料庫 '%5' 的參照,不符合目前的記錄集合。資料庫引擎將不允許為此執行個體完成修復,直到不符合的資料庫恢復為止。如果資料庫真的無法再使用或不再需要,從此錯誤修復的程序可在 Microsoft 知識庫文章中找到,或可遵循在此訊息底部的「其他資訊」連結。
�%1 (%2) %3記錄檔 %4 已遺失 (錯誤 %5) 且無法使用。如果復原時需要此記錄檔,則必須提供良好的記錄檔副本,才能成功完成復原。
�%1 (%2) %3記錄檔 %4 到 %5 的範圍遺失 (錯誤 %6),而且無法使用。如果復原時需要這些記錄檔,則必須提供良好的記錄檔副本,才能成功完成復原。
d%1 (%2) %3記錄截斷失敗,因為並未成功地複製修復所需的所有記錄檔。
L%1 (%2) %3無法在記錄檔 %4 上排程記錄寫入。錯誤 %5。
�%1 (%2) %3嘗試開啟包含 "%5" 且名稱為 "%4" 的裝置失敗,發生系統錯誤 %7: "%8"。作業將會失敗,錯誤為 %6。
,%1 (%2) %3資料庫 %4 需要記錄檔 %5-%6 才能復原所有認可的資料。復原最多只能找到記錄檔: %7,找不到記錄產生 %8。如果找不到記錄檔,則可以手動復原資料庫,但是會導致遺失已認可的資料。 
%n詳細資料:
%n%t記錄檔目錄: %9
%1 (%2) %3資料庫 %4 已經遺失 %5 個已認可的記錄檔 (%6-%7)。不過,遺失的記錄檔恢復已允許 ESE 將這個資料庫復原至一致的狀態,但仍有資料遺失。復原最多只能找到 %8 個記錄檔。
%n詳細資料:
%n%t記錄檔目錄: %9
�%1 (%2) %3記錄檔 %4 已損毀、無效或無法存取 (錯誤 %5) 而且無法使用。如果找不到記錄檔,則可以手動復原資料庫,但是會導致遺失已認可的資料。
%n詳細資料:
%n%t記錄檔目錄: %6
%1 (%2) %3記錄檔 %5 (第 %6 代) 有損毀或無效的記錄 (%7),ESE 已移除毀損的記錄部份,因為這些認可的記錄檔已指定為不需要,以便 ESE (透過第 %4 代) 將任何附加的資料庫復原為一致狀態,但仍有資料遺失。 
 %1 (%2) %3ESE 已移除 %4 個已認可的記錄檔 (%5-%6),以按順序維護記錄資料流。不過,遺失的記錄檔恢復已允許 ESE 復原為一致狀態,但仍有資料遺失。復原透過記錄檔最多只能復原 %7。
%n詳細資料:
%n%t記錄檔目錄: %8
(%1 (%2) %3在偵測不按順序的記錄之前,復原最多只能找到記錄檔 %4 (第 %5 代),而且找不到記錄檔 %6 (第 %7 代)。如果找不到記錄檔,則可以手動復原資料庫,但是會導致遺失已認可的資料。
%n詳細資料:
%n%t記錄檔目錄: %8
%1 (%2) %3在位移 %5 從檔案 "%4" 讀取 %6 位元組的記錄範圍驗證失敗,因為總和檢查碼記錄檔中的記錄損毀。讀取作業將因錯誤 %7 而失敗。如果此情況持續出現,請從先前的備份還原記錄檔。
�%1 (%2) %3因為遺失的排清偵測時間戳記不符,所以從檔案 "%4" 的位移 %5 處 (資料庫分頁 %8) 讀取 %6 個位元組驗證失敗。讀取作業將失敗,錯誤為 %7。
%n資料庫分頁 %8 上的排清狀態為 %9,而排清對應頁面 %10 上的排清狀態為 %11。
%n如果此狀況持續發生,請從先前的備份還原資料庫。這個問題很有可能導因於硬體錯誤。請連絡您的硬體廠商以取得進一步診斷此問題的協助。
�%1 (%2) %3資料庫引擎嘗試在資料庫 %5 的分頁 %4 進行全新寫入作業。此作業的目的是為了更正先前讀取該頁的錯誤。
�%1 (%2) %3從檔案 "%4" (位移 %5;%6 個位元組) 讀取要求未完成,並已耗時 %7 秒。這個問題很有可能是因為硬體錯誤。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3寫入檔案 "%4" (位移 %5;%6 個位元組) 的要求未完成達 %7 秒。這個問題很有可能是因為硬體錯誤。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3對於檔案 "%4" 在頁碼 "%5" 處的修補要求失敗,錯誤為 %6。如果此情況持續出現,請使用先前的備份組還原。
�%1 (%2) %3嘗試決定包含 "%4" 的磁碟區最小 I/O 區塊大小失敗。預設會使用 512 位元組的磁區大小。
L%1 (%2) %3建立暫時資料庫 %4 的嘗試失敗,錯誤為 %5。
�%1 (%2) %3A request for a node on an empty page (Pgno: %7, Flags: %9) has been made (error %4) for a B-Tree (ObjectId: %5, PgnoRoot: %6) of database %8. This is typically due to a lost I/O from 
storage hardware. Please check with your hardware vendor for latest firmware revisions, make changes to your controller's caching parameters, use crash consistent hardware with Forced
Unit Access support, and/or replace faulty hardware.
0%1 (%2) %3Database %4: Page %5 failed verification due to a timestamp mismatch at log position %10.  The remote ("before") timestamp persisted to the log record was %6 but the actual timestamp on the page was %7 (note: DbtimeCurrent = %9). This indicates the active node lost a flush (error %8). This problem is likely due to faulty hardware "losing" one or more flushes on this page sometime in the past on the active node. Please contact your hardware vendor for further assistance diagnosing the problem.%n
Additional information:%n
%tSource: %11%n
4%1 (%2) %3Database %4: Page %5 failed verification due to a timestamp mismatch at log position %10.  The remote ("before") timestamp persisted to the log record was %6 but the actual timestamp on the page was %7 (note: DbtimeCurrent = %9). This indicates the passive node lost a flush (error %8). This problem is likely due to faulty hardware "losing" one or more flushes on this page sometime in the past on the passive node. Please contact your hardware vendor for further assistance diagnosing the problem.%n
Additional information:%n
%tSource: %11%n
�%1 (%2) %3Database %4: Page %5 logical data checksum %6 failed to match logged scan check %7 checksum (seed %8) at log position %9.%n
Additional information:%n
%tSource: %10%n
�%1 (%2) %3Database %4: Page %5 was shown to be uninitialized at log position %8, while the remote ("before") timestamp persisted to the log record was %6 (note: DbtimeCurrent = %7).%n
Additional information:%n
%tSource: %9%n
h%1 (%2) %3Database %4: Page %5 (objid %6) has a logical corruption of type '%7'.
%nDetails: %8
t%1 (%2) %3過去記錄累積的區段總合檢查碼與記錄檔 %4 不相符,預期: %5,實際: %6。
�%1 (%2) %3因為持續遺失的排清偵測時間戳記不符,所以從檔案 "%4" 的位移 %5 處 (資料庫分頁 %8) 讀取 %6 個位元組驗證失敗。讀取作業將失敗,錯誤為 %7。
%n資料庫分頁 %8 上的排清狀態為 %9,而排清對應頁面 %10 上的排清狀態為 %11。
%n如果此狀況持續發生,請從先前的備份還原資料庫。這個問題很有可能導因於硬體錯誤。請連絡您的硬體廠商以取得進一步診斷此問題的協助。
0%1 (%2) %3Database %4: Page %5 appears to be uninitialized at log position %10 on the remote node.  The remote ("before") timestamp persisted to the log record was %6 but the actual timestamp on the page was %7 (note: DbtimeCurrent = %9). This indicates the active node lost a flush (error %8). This problem is likely due to faulty hardware "losing" one or more flushes on this page sometime in the past on the active node. Please contact your hardware vendor for further assistance diagnosing the problem.%n
Additional information:%n
%tSource: %11%n
|%1 (%2) %3記錄產生 (%4) 太低 (%5),此資料庫引擎無法支援或重新執行 (最低支援需求為 %6)。
|%1 (%2) %3記錄產生 (%4) 太高 (%5),此資料庫引擎無法支援或重新執行 (最大支援需求為 %6)。
�%1 (%2) %3The log generation's [%4] version %5 is higher than the maximum version configured by the application %6. Current engine format version parameter setting: %7
�%1 (%2) %3Database %4 has a page (pgno %5) with too few lines, operation attempted on line %6, actual number of lines on page %7.
�%1 (%2) %3Database %4: A compressed LV chunk failed verification during decompression due to a checksum mismatch. This indicates a logical corruption in the compress/decompress pipeline.
pgnoFDP = %5. Key = %6.
%1 (%2) %3An attempt to flush to the file/disk buffers of "%4" failed after %5 seconds with system error %6: "%7".  The flush operation will fail with error %8.  If this error persists then the file system may be damaged and may need to be restored from a previous backup.
0%1 (%2) %3The log file at "%4" is corrupt with reason '%5'. Last valid segment was %6, current segment is %7. The expected checksum was %8 and the actual checksum was %9. The read completed with error-code %10.  If this condition persists then please restore the logfile from a previous backup.
`%1 (%2) %3Failed looking up restore-map entry for database %4 with unexpected error %5.
�%1 (%2) %3The log segment read from the file "%4" at offset %6 (segment number %5) failed verification. Bit %7 was corrupted and has been corrected.  This problem is likely due to faulty hardware and may continue. Transient failures such as these can be a precursor to a catastrophic failure in the storage subsystem containing this file.  Please contact your hardware vendor for further assistance diagnosing the problem.
<%1 (%2) %3Database %4: Page %5 failed verification due not containing any data at log position %6 (currently replaying log position %7).  Recovery/restore will fail with error %8.  If this condition persists then please restore the database from a previous backup. This problem is likely due to faulty hardware "losing" one or more flushes on this page some time in the past. Please contact your hardware vendor for further assistance diagnosing the problem.
%nAdditional information:
%n%tWithin initial required range: %9
%n%tTotal number of pages affected: %10
P%1 (%2) %3Database %4: Data in line %5 on pgno %6 failed to decompress.
�%1 (%2) %3Database %4: Page %5 was shown to be beyond the end of file at log position %8, while the remote ("before") timestamp persisted to the log record was %6 (note: DbtimeCurrent = %7).%n
Additional information:%n
%tSource: %9%n
�%1 (%2) %3There is a gap in sequence number following logfile generation %4. Highest logfile generation present is %5.
x%1 (%2) %3資料庫引擎在資料表 %4 中遇到一個意外的重複關鍵字。有一筆記錄已經遺漏。
T%1 (%2) %3資料庫引擎無法無法找到檔案 %5 中的輸入點 %4。
 %1 (%2) %3資料庫 '%4': 背景清除跳過頁面。資料庫可能在離峰時間藉由加寬線上維護視窗的方式而受益。如果此訊息持續出現,您可以執行離線磁碟重組以移除資料庫中所有跳過的頁面。資料庫可能從線上或受益。
�%1 (%2) %3資料庫 '%4': 在嘗試回收 B 樹 (物件識別符 %7) 上的空間時,資料庫引擎遺失了未使用的頁面 %5-%6。只有在執行了離線磁碟重組之後,才能重新回收空間。
�%1 (%2) %3地區設定識別碼 %4 (%5 %6) 無效、未安裝於此機器上或因系統錯誤 %7: "%8" 而無法驗證。操作將因錯誤 %9 而失敗。
T%1 (%2) %3資料表 '%5' 中的欄 '%4' 已轉換為一個標記了的欄。
T%1 (%2) %3資料表 '%5' 中的欄 '%4' 已轉換為一個未標記的欄。
X%1 (%2) %3資料表 '%5' 中的欄 '%4' 已從二進位轉換為長二進位。
P%1 (%2) %3資料表 '%5' 中的欄 '%4' 已從文字轉換為長文字。
�%1 (%2) %3由於 Windows 版本已經從 %5.%6.%7 SP%8 升級至 %9.%10.%11 SP%12,資料庫引擎正開始對資料庫 '%4' 進行索引清除。這個訊息只是作為資訊參考之用,並不表示資料庫中有任何問題。
�%1 (%2) %3由於 Windows 版本已經升級至 %5.%6.%7 SP%8,資料庫引擎正開始對資料庫 '%4' 進行索引清除。這個訊息只是作為資訊參考之用,並不表示資料庫中有任何問題。
�%1 (%2) %3資料庫 '%4': 此系統中的 Windows 版本升級之後,作為一種預防措施,將重建資料表 '%6' 中的二級索引 '%5'。這個訊息只是作為資訊參考之用,並不表示資料庫中有任何問題。
T%1 (%2) %3資料庫引擎已成功完成對資料庫 '%4' 的索引清除。
%1 (%2) %3資料庫 '%4': 資料表 '%6' 的主要索引 '%5 在排序文件庫時已過時。若以此狀態使用 (即不重建),可能會顯示損毀,或是發生更多損毀。如果沒有之後的事件顯示重建該索引,請重組資料庫以重建該索引。
%1 (%2) %3資料庫 '%4': 資料表 '%6' 的次要索引 '%5' 在排序文件庫時已過時,若以此狀態使用 (即不重建),可能會顯示損毀,或是發生更多損毀。如果沒有之後的事件顯示重建該索引,請重組資料庫以重建該索引。
\%1 (%2) %3資料庫引擎正在將資料庫 '%4' 從格式 %5 轉換為格式 %6。
`%1 (%2) %3資料庫引擎已成功地將資料庫 '%4' 從格式 %5 轉換為格式 %6。
�%1 (%2) %3已嘗試使用資料庫 '%4',但此資料庫上的轉換沒有成功。請從備份資料庫還原,然後重新執行資料庫轉換。
 %1 (%2) %3資料庫 '%4': 資料庫引擎已經在B 樹 (物件識別符: %6, PgnoRoot: %7) 上建立一個 %5 空間樹節點的記憶體中的快取。空間快取是在 %8 微秒中建立。這個訊息只是作為資訊參考之用,並不表示資料庫中有任何問題。
�%1 (%2) %3已嘗試附加資料庫 '%4',但是該資料庫是從某個備份集中還原。該備份集並未啟動硬修復或並未成功地完成。
@%1 (%2) %3無法轉換記錄 %4:%5:%6 的記錄格式。
�%1 (%2) %3資料庫 '%4': B 樹識別符 (ObjectIDs) 用完。執行資料庫的離線磁碟重組可以取回已釋放/未使用的 B 樹識別符。
�%1 (%2) %3資料庫 '%4': 可用的 B 樹識別符 (ObjectIDs) 已幾乎被完全用完。執行資料庫的離線磁碟重組可以取回已釋放/未使用的 B 樹識別符。
�%1 (%2) %3此例項 (%4) 的版本儲存已經到達 %5MB 的最大容量。有可能是長時間執行的異動妨礙版本儲存的清除動作,而使得版本儲存不斷增大。更新將會被拒絕直到長時間執行的異動已經完全提交或回復為止。
%n可能的長時間執行異動:
%n%tSessionId: %6
%n%tSession-context: %7
%n%tSession-context ThreadId: %8
%n%tCleanup: %9
%n%tSession-trace:
%n%10
t%1 (%2) %3此例項 (%4) 的版本儲存無法增大,因為受到作業系統記憶體不足的錯誤訊息。有可能是長時間執行的異動妨礙版本儲存的清除動作,而使得版本儲存不斷增大。更新將會被拒絕直到長時間執行的異動已經完全提交或回復為止。
%n此例項目前的版本儲存大小: %5Mb
%n此例項的最大版本儲存大小: %6Mb
%n整體記憶體將會在所有版本儲存中預存: %7Mb
%n可能的長時間執行異動:
%n%tSessionId: %8
%n%tSession-context: %9
%n%tSession-context ThreadId: %10
%n%t清理: %11
%n%tSession-trace:
%n%12
D%1 (%2) %3資料庫引擎不支援 LCMapString() 旗標 %4。
�%1 (%2) %3資料庫引擎已更新了資料庫 %5 的索引項目 %4,因為 NLS 版本的變更。這個訊息僅供參考並不表示資料庫有問題。
l%1 (%2) %3資料庫引擎無法更新資料庫 %5 的索引項目,因為資料庫是唯讀的。
l%1 (%2) %3資料庫 '%4': 當嘗試移到 B 型樹狀結構
中的下一個或上一個節點時,資料庫引擎需要 %17 毫秒 (錯誤時需等候 %18 毫秒) 以略過
 %8 個頁面 (%19 個頁面有錯誤) 中 %7 個看不見的節點。有可能這些看不見的節點
是已經標示為刪除但尚未清除的節點。
資料庫可能因加寬在離峰時間的線上維護時間窗口,
而能清除這類節點和收回其空間。
如果這個訊息持續顯示,
可能需要執行離線磁碟重組,以移除已標示為刪除
但是尚未從資料庫清除的所有節點。
%n%t名稱: %5
%n%t擁有資料表: %6
%n%tObjectId: %9
%n%tPgnoRoot: %10
%n%t類型: %11
%n%t無版本控制的刪除: %12
%n%t未認可的刪除: %13
%n%t已認可的刪除: %14
%n%t看不見的插入: %15
%n%t已篩選: %16\r\n%n%tDbtime 分散: %20
D%1 (%2) %3資料庫 '%4': 當嘗試移到 B 型樹狀結構中的下一個或
上一個節點時,資料庫引擎用了 %21 毫秒 (錯誤時等候 %22 毫秒) 以略過 %8 個頁面 (%23 個頁面有錯誤) 中 %7 個
看不見的節點。此外,因為上次報告這個訊息為
 %16 個小時前,所以在此 B 型樹狀結構中的瀏覽期間發生過多
看不見節點的 %17 個其他事件 (總共略過 %19 個頁面中的
 %18 個節點)。有可能這些
看不見的節點是已經標示為刪除但尚未清除的節點。
資料庫可能因加寬在離峰時間的線上維護時間窗口,
而能清除這類的節點和收回其空間。
如果這個訊息持續顯示,
可能需要執行離線磁碟重組,
以移除已標示為刪除但是尚未從資料庫清除
的所有節點。
%n%t名稱: %5
%n%t擁有資料表: %6
%n%tObjectId: %9
%n%tPgnoRoot: %10
%n%t類型: %11
%n%t無版本控制的刪除: %12
%n%t未認可的刪除: %13
%n%t已認可的刪除: %14
%n%t看不見的插入: %15
%n%t已篩選: %20
%n%tDbtime 分散: %24
�%1 (%2) %3此例項的版本儲存區 (%4) 有長時間執行異動且超過異動大小上限。 
%n此例項目前的版本儲存區大小: %5Mb
%n此例項的異動大小上限: %6Mb
%n此例項的版本儲存區大小上限: %7Mb
%n長時間執行異動:
%n%tSessionId: %8
%n%tSession-context: %9
%n%tSession-context ThreadId: %10
%n%t清理: %11
%n%tSession-trace:
%n%12
�%1 (%2) %3檔案系統回報 %4 上的資料庫檔案磁區大小 %5 超過 %6 的分頁大小。這樣可能會造成高磨損的寫入毀損和/或遺失清除導致的資料庫毀損。
�%1 (%2) %3檔案系統回報在 %4 的記錄檔含有不支援的磁區大小 %5,改為使用 4096 的磁區大小。這可能會造成異動持久性遺失。
�%1 (%2) %3已暫停復原 (%4 毫秒) 以允許完成較舊的唯讀交易。若此狀態持續,可能造成過時複本。
�%1 (%2) %3已長時間暫停復原 (%4 毫秒) 以允許完成較舊的唯讀交易。若此狀態持續,可能造成過時複本。
H%1 (%2) %3無法附加清除對應檔 "%4",發生錯誤 %5。
@%1 (%2) %3將刪除清除對應檔 "%4" 。原因: %5。
\%1 (%2) %3將建立新的清除對應檔 "%4",以啟用保留遺失清除偵測。
�%1 (%2) %3在清除對應檔案 "%6" 上驗證頁面 %5 時發生錯誤 %4。資料庫頁面的清除類型將設為 '未知' 狀態。
x%1 (%2) %3在清除對應檔 " %5" 的頁面 %4 上偵測到時間戳記不一致 (若已停用清除對應持續性,則為空白)。清除對應的時間戳記上限為 %6,但資料庫頁面 %7 的時間戳記為 %8。若已啟用清除對應持續性,此問題可能是硬體故障所致。請連絡您的硬體廠商,取得進一步協助以診斷問題。
�%1 (%2) %3在排清對應檔 "%5" 上驗證標頭頁面時發生錯誤 %4。排清對應檔將不會通過驗證。
%n其他資訊: %6
l%1 (%2) %3記錄格式功能版本 %5 因參數 %4 控制的目前記錄格式 %6 而無法使用。
p%1 (%2) %3資料庫格式功能版本 %5 因參數 %4 控制的目前記錄格式 %6 而無法使用。
�%1 (%2) %3 Out of date NLS sort version detected on the database '%4' for Locale '%5', index sort version: (SortId=%6, Version=%7), current sort version: (SortId=%8, Version=%9).
�%1 (%2) %3A session has an outstanding transaction causing the checkpoint depth (of %4 logs) to exceed a quarter of the JET_paramCheckpointTooDeep setting.%n
%n
Details:%n
Transaction Context Info: %5%n
Transaction Start Times: %6%n
L%1 (%2) %3線上磁碟重組正開始完整檢查資料庫 '%4'。
%1 (%2) %3線上磁碟重組已完成對資料庫 '%4' 的完整檢查,正在釋放 %5 頁。這項作業已在 %6 啟動且共執行了 %7 秒,在過去 %9 天內需要 %8 次呼叫。 自從資料庫建立之後,已經完整重組 %10 次。
�%1 (%2) %3線上磁碟重組正在資料庫 '%4' 上繼續它的作業。這項作業已在 %5 啟動且執行了 %6 天。
%1 (%2) %3線上磁碟重組已完成還原對資料庫 '%4' 的檢查,正在釋出 %5 個分頁。這項作業已在 %6 啟動且共執行了 %7 秒,在過去 %9 天內需要 %8 次呼叫。 自從資料庫建立之後,已經完整重組 %10 次。
�%1 (%2) %3對資料庫 '%4' 進行的線上磁碟重組被中斷並終止。對資料庫啟動下一次線上磁碟重組,將從中斷點還原整理。
�%1 (%2) %3遇到意外錯誤 %5 後,對資料庫 '%4' 的進行線上磁碟重組提前終止。對資料庫啟動下一次線上磁碟重組,將從中斷點還原整理。
D%1 (%2) %3已開始對資料庫 %4 進行線上零位調整
4%1 (%2) %3在%5 秒鐘後,完成對資料庫 %4 進行的線上零位調整,出現錯誤 %6%n
%7 頁面%n
%8 空白頁面%n
%9 上一次零位調整後未變更的頁面%n
%10 未使用的零位調整頁面%n
%11 發現已使用的頁面%n
%12 刪除的零位調整記錄%n
%13 取消參考
L%1 (%2) %3線上磁碟重組已經開始通過串流檔案 '%4'。
D%1 (%2) %3線上重組已經完成通過串流檔案 '%4'。
X%1 (%2) %3串流檔案的線上磁碟重組 '%4' 將檔案縮小 %5 位元組。
d%1 (%2) %3串流檔案 '%4' 的線上磁碟重組因遇到意外錯誤 %5 而永久中止。
D%1 (%2) %3串流檔案 '%4' 的線上零位調整已啟動。
�%1 (%2) %3串流檔案 '%4' 的線上零位調整在 %5 秒後完成,錯誤 %6%n
%7 頁面%n
%8 未使用的零位調整%n
P%1 (%2) %3線上磁碟重組已成功地於串流檔案 '%4' 上停止。
(%1 (%2) %3下列資料庫在過去 60 分鐘內,線上磁碟重組已暫停一或多次: '%4'。ESE 資料庫快取的大小不足以對所列的資料庫同時執行線上磁碟重組。動作: 錯開所列資料庫的線上維護時程,或增加伺服器中的實體 RAM 數量。
l%1 (%2) %3下列資料庫在過去 60 分鐘內,線上磁碟重組已繼續一或多次: "%4'。
d%1 (%2) %3線上維護正在啟動資料庫 '%4' 的資料庫總和檢查碼背景工作。
`%1 (%2) %3線上維護正在啟動資料庫 '%4' 的資料庫分頁清空背景工作。
�%1 (%2) %3線上維護正在繼續資料庫 '%4' 的資料庫總和檢查碼背景工作。這項作業已在 %5 啟動且執行了 %6 天。
�%1 (%2) %3線上維護正在繼續資料庫 '%4' 的資料庫清空背景工作。這項作業已在 %5 啟動且執行了 %6 天。
%1 (%2) %3資料庫 '%4' 的線上維護資料庫總和檢查碼背景工作已完成。這項作業已在 %5 啟動且總計執行了 %6 秒,在過去 %8 天內需要 %7 次呼叫。操作摘要:
%n
已查看 %9 頁%n
%10 個錯誤總和檢查碼%n
未初始化 %11 頁
�%1 (%2) %3資料庫 '%4' 的線上維護資料庫清空背景工作已完成。這項作業已在 %5 啟動且總計執行了 %6 秒,在過去 %8 天內需要 %7 次呼叫。操作摘要:
%n
已查看 %9 頁%n
%10 個錯誤總和檢查碼%n
未初始化 %11 頁%n
上一次清空後 %12 頁未變更%n
已清空 %13 個未使用的頁%n
已查看 %14 個已使用的分頁%n
已將 %15 個刪除的記錄清空%n
已將 %16 個未參考的資料區塊清空
t%1 (%2) %3資料庫 '%4' 的線上維護資料庫總和檢查碼背景工作在 %6 秒後發生錯誤 %5。
l%1 (%2) %3資料庫 '%4' 的線上維護資料庫清空背景工作在 %6 秒後發生錯誤 %5。
�%1 (%2) %3資料庫 '%4' 的線上維護資料庫總和檢查碼背景工作已中斷並已終止。下次在此資料庫上啟動線上維護資料庫總和檢查碼時,將從中斷點繼續。
�%1 (%2) %3資料庫 '%4' 的線上維護資料庫清空背景工作已中斷並已終止。下次在此資料庫上啟動線上維護資料庫總和檢查碼時,將從中斷點繼續。
X%1 (%2) %3因為頁面總和檢查碼不符,所以從檔案 "%4" 的位移 %5 處 (資料庫頁面 %6) 讀取資料庫頁面的驗證失敗。如果此情況持續出現,則請從前一個備份還原資料庫。這個問題很有可能是因為硬體錯誤。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3
線上磁碟重組已重組資料庫 '%4' 的資料表 '%5' 中的索引 '%6'。這項作業已在 %7 啟動。%n
已造訪 %8 頁%n
已釋放 %9 頁%n
合併 %10 個組件%n
已移動 %11 頁
0%1 (%2) %3下列資料庫在過去 60 分鐘內,線上維護資料庫清空已暫停一或多次: '%4'。ESE 資料庫快取的大小不足以對所列的資料庫同時執行線上分頁清空。動作: 錯開所列資料庫的線上維護時程,或增加伺服器中的實體 RAM 數量。
t%1 (%2) %3下列資料庫在過去 60 分鐘內,線上維護資料庫清空已繼續一或多次: '%4'。
�%1 (%2) %3Online Maintenance Database Checksumming background task has completed for database '%4'. This pass started on %5 and ran for a total of %6 seconds (over %7 days) on %8 pages.
%n
Last Runtime Scan Stats: %9
�%1 (%2) %3資料庫 '%4' 的線上維護資料庫總和檢查碼背景工作未準時完成。這項作業已在 %5 啟動,目前已執行了 %6 秒 (超過 %7 天)。
\%1 (%2) %3資料庫 '%4' 的資料庫維護背景工作無法啟動,錯誤為 %5。
d%1 (%2) %3Database Maintenance has completed a full pass on database '%4'. This pass started on %5 and ran for a total of %6 seconds (%7 days).  This database maintenance task exceeded the %8 day maintenance completion threshold.  One or more of the following actions should be taken:  increase the IO performance/throughput of the volume hosting the database, reduce the database size, and/or reduce non-database maintenance IO.
%n
%9 pages seen%n
Average free space on Record pages: %10 (%11 pages scanned)%n
Average free space on LV pages: %12 (%13 pages scanned)%n
Last Runtime Scan Stats: %10%n
D%1 (%2) %3正在為資料庫 '%4' 啟動資料庫維護。
<%1 (%2) %3Database Maintenance has completed a full pass on database '%4'. This pass started on %5 and ran for a total of %6 seconds.
%n
%7 pages seen%n
Average free space on Record pages: %9 (%10 pages scanned)%n
Average free space on LV pages: %11 (%12 pages scanned)%n
Last Runtime Scan Stats: %8%n
�%1 (%2) %3資料庫 '%4' 的資料庫維護正在繼續,從頁面 %5 開始。這項作業已在 %6 啟動,目前已執行 %7 天。
%1 (%2) %3資料庫 '%4' 的 NTFS 檔案屬性大小為 %5 個位元組,超過 %6 個位元組的閾值。必須重新植入資料庫檔案,或從複製或備份還原資料庫檔案,以防資料庫檔案因為檔案系統限制而無法增長。
H%1 (%2) %3The periodic database file trimming operation started.
�%1 (%2) %3The periodic database file trimming operation finished successfully and trimmed the database file by %4 pages.
�%1 (%2) %3The periodic database file trimming operation was not able to trim the database file because there is not enough internal free space available.
t%1 (%2) %3The periodic database file trimming operation was not able to trim the database file. Result %4.
�%1 (%2) %3資料庫維護正在資料庫 '%4' 上執行。這項作業已在 %5 啟動且已執行了 %6 小時。
%n
已查看 %7 頁%n
0%1 (%2) %3Online Maintenance Database Checksumming background task is aborted for database '%4' at page %5, due to client request (typically because of critical redo activity must be done quickly).%n
The last properly completed checksumming task was on %6.%n
%n
Last Runtime Scan Stats: %7%n
%1 (%2) %3資料庫 '%4' 線上維護資料庫總和檢查碼背景工作已完成遭到中斷且不完整的掃描。中斷原因通常為用戶端要求 (通常為必須盡速完成的重大重做活動)。%n
上次完整完成的總和檢查碼工作是在 %5。
�%1 (%2) %3線上維護正在恢復資料庫 '%4' 的資料庫總和檢查碼背景工作,為了完成此工作,已略過 %5 個頁面 (%6%%)。之前停止: %7,此次開始: %8。%n
T%1 (%2) %3The database file shrinkage operation completed successfully on database '%4'.%n
Initial file size: %7 bytes (%8 page(s)).%n
Final file size: %9 bytes (%10 page(s)).%n
Initial owned space: %11 bytes (%12 page(s)).%n
Final owned space: %13 bytes (%14 page(s)).%n
Data moved: %15 bytes (%16 page(s)).%n
Return code: %17%n
Stop reason: %18%n
Total time: %5 minute(s) and %6 second(s).%n
Pct. time in extent maintenance: %19%%%n
Pct. time in file truncation: %20%%%n
Pct. time in page categorization: %21%%%n
Pct. time in data move: %22%%%n
Pct. remaining time: %23%%%n
D%1 (%2) %3The database file shrinkage operation failed on database '%4'.%n
Initial file size: %7 bytes (%8 page(s)).%n
Final file size: %9 bytes (%10 page(s)).%n
Initial owned space: %11 bytes (%12 page(s)).%n
Final owned space: %13 bytes (%14 page(s)).%n
Data moved: %15 bytes (%16 page(s)).%n
Error code: %17%n
Stop reason: %18%n
Total time: %5 minute(s) and %6 second(s).%n
Pct. time in extent maintenance: %19%%%n
Pct. time in file truncation: %20%%%n
Pct. time in page categorization: %21%%%n
Pct. time in data move: %22%%%n
Pct. remaining time: %23%%%n
h%1 (%2) %3系統參數的最小快取大小 (%4) 比工作階段快取數量 (%5) 少 4 倍。
\%1 (%2) %3系統參數的最大快取大小 (%4) 少於最小的快取大小 (%5)。
`%1 (%2) %3系統參數的最大快取大小 (%4) 少於停止清理清除閾值 (%5)。
h%1 (%2) %3系統參數的停止清理清除限制值 (%4) 少於起始清理清除閾值 (%5)。
�%1 (%2) %3系統參數記錄的緩衝區大小 (%4 磁區) 大於最大容量 %5 KB (記錄檔案大小減去保留空間)。
\%1 (%2) %3系統參數的最大版本頁面 (%4) 少於喜好的版本頁面 (%5)。
l%1 (%2) %3由於實體記憶體的限制,系統參數的喜好版本頁面已從 %4 變更為 %5。
t%1 (%2) %3系統參數的最大開啟表 (%4) 少於喜好的開啟資料表 (%5)。請檢查登錄設定。
�%1 (%2) %3系統參數喜好的版本頁面 (%4) 大於最大的版本頁面 (%5)。喜好的版本頁面已從 %6 變更為 %7。
�%1 (%2) %3在嘗試記錄事務提交時,由於錯誤 %4 使資料庫引擎失敗。為確保資料庫的一致性,已終止程序。只需重新啟動程序,即可以強制修復資料庫並使資料庫返回正常關機狀態。
4%1 (%2) %3Tag: %6. Internal trace: %4 (%5).
%1 (%2) %3資料庫引擎偵測到有數個執行緒不合法地使用相同的資料庫工作階段執行資料庫作業。
%n%tSessionId: %4
%n%tSession-context: %5
%n%tSession-context ThreadId: %6
%n%t目前的 ThreadId: %7
%n%tSession-trace:
%n%8
P%1 (%2) %3資料庫引擎偵測到相同工作階段的兩個不同游標正在相同時間嘗試非法更新相同的記錄。
%n%tSessionId: %4
%n%tThreadId: %5
%n%t資料庫: %6
%n%t資料表: %7
%n%t目前游標: %8
%n%t游標擁有的原始更新: %9
%n%t書籤大小 (字首/字尾): %10
%n%tSession-trace:
%n%11
L%1 (%2) %3已使用測試 API 損毀資料庫 '%5' 的第 %4 頁。
�%1 (%2) %3資料庫引擎已修復資料庫 '%5' 在頁面 %4 上的損毀。雖然已修復損毀,但損毀的來源可能來自有瑕疵的硬體,故應加以調查。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
�%1 (%2) %3有相當大的一部分資料庫緩衝快取已寫出至系統分頁檔。這可能會導致效能嚴重下降。
%n如需完整的可能原因詳細資訊,請參閱說明連結。
%n先前的快取常駐狀態: %4% (%6 個緩衝區中的 %5 個) (%7 秒前)
%n目前的快取常駐狀態: %8% (%10 個緩衝區中的 %9 個)
%n目前快取大小與目標: %11% (%12 MB)
%n實體記憶體/RAM 大小: %13 MB
|%1 (%2) %3偵測到暫時性記憶體損毀。執行「Windows 記憶體診斷」工具和/或調查硬體問題。
X%1 (%2) %3Terminating process due to non-recoverable failure: %4 (%5). Tag: %6.
x%1 (%2) %3正在終止處理序,因為發生無法復原的失敗: 資料庫 '%6' 上的 %4 (%5) 作業中。
�%1 (%2) %3資料庫快取大小維護工作已花費 %4 秒但尚未完成。這可能會導致效能嚴重下降。
目前的快取大小為 %5 個緩衝區,超過了設定的快取限制 (目標的百分之 %6)。
快取大小維護收回了 %7 個緩衝區,進行了 %8 次排清嘗試,並成功排清了 %9 個緩衝區。自從觸發維護以來執行了 %10 次。
%1 (%2) %3資料庫引擎已經修復資料庫 '%6' 在 %4 - %5 頁面的損毀。雖然已修復損毀,但損毀的來源可能來自有瑕疵的硬體,故應加以調查。請連絡您的硬體廠商以取得更多的協助來診斷此問題。
p%1 (%2) %3有部分資料庫緩衝區快取已從系統分頁檔還原,且目前再次常駐於記憶體。在此之前,有部分資料庫緩衝區快取已寫出至系統分頁檔,並造成效能降低。
%n先前的快取常駐狀態: %4% (%6 個緩衝區中的 %5 個) (%7 秒前)
%n目前的快取常駐狀態: %8% (%10 個緩衝區中的 %9 個)
�%1 (%2) %3先前的 ESE 應用程式執行個體未設定參數 %4 的單一值,但目前的 ESE 應用程式已設定為不同的值。此為系統參數不相符,所有 ESE 應用程式的所有全域系統參數必須相同。
�%1 (%2) %3先前的 ESE 應用程式執行個體未設定參數 %4,但目前的 ESE 應用程式內已設定該參數。此為系統參數不相符,所有 ESE 應用程式的所有全域系統參數必須相同。
�%1 (%2) %3先前的 ESE 應用程式執行個體設定了參數 %4,但未在目前的 ESE 應用程式內設定該參數。此為系統參數不相符,所有 ESE 應用程式的所有全域系統參數必須相同。
X%1 (%2) %3由於 Beta 網站模式設定 %6,已在 %5 啟用 Beta 功能 %4。
l%1 (%2) %3以下設定使資源模擬失敗:
\t\t%4:\t%5
\t\t%6:\t%7
\t\t%8:\t%9
\t\t%10:\t%11
0%1 (%2) %3允許資源模擬失敗 %4。
0%1 (%2) %3拒絕資源模擬失敗 %4。
8%1 (%2) %3JET 呼叫 %4 返回錯誤 %5。%6 (%7)
@%1 (%2) %3JET 行內錯誤 %4 跳到標註 %5。%6 (%7)
0%1 (%2) %3陰影複製函數 %4() = %5。
<%1 (%2) %3陰影複製例項 %4 凍結已開始。
H%1 (%2) %3陰影複製例項 %4 在凍結時發生錯誤 %5。
<%1 (%2) %3陰影複製例項 %4 凍結已結束。
D%1 (%2) %3陰影複製例項 %4 凍結逾時 (%5 毫秒)。
\%1 (%2) %3陰影複製執行個體 %4 已開始。這將是完整的陰影複製。
D%1 (%2) %3陰影複製執行個體 %4 已成功地完成。
<%1 (%2) %3陰影複製執行個體 %4 已中止。
\%1 (%2) %3陰影複製執行個體 %4 已開始。這將是增量的陰影複製。
\%1 (%2) %3陰影複製執行個體 %4 已開始。這將是複製的陰影複製。
\%1 (%2) %3陰影複製執行個體 %4 已開始。這將是差異的陰影複製。
�%1 (%2) %3An attempt to initialize the FPGA failed with error %4. Please make sure that the FPGA hardware is present and configured correctly.
�%1 (%2) %3An attempt to acquire an FPGA slot during initialization failed. This indicates that there are more processes trying to use the FPGA than the available slots.
�%1 (%2) %3An FPGA operation failed with error %4. This error was classified as a transient failure. The engine has encountered the following FPGA failures since it started:
Permanent = %5, Transient = %6, HEX Resets = %7
�%1 (%2) %3An FPGA operation failed with error %4. This error was classified as a permanent FPGA failure. The engine has encountered the following FPGA failures since it started:
Permanent = %5, Transient = %6, HEX Resets = %7
t%1 (%2) %3An attempt to acquire an FPGA slot event during initialization failed with system error %4: "%5".
NOOP_FAILURE_TAG_ID
�%1 (%2) %3組態錯誤導致資料庫 '%4' ('%5') 無法正常操作。資料庫錯誤組態、使用權限問題或儲存相關的問題都可能導致錯誤發生。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3讀取驗證或 I/O 錯誤導致資料庫 '%4' ('%5') 無法正常操作。檢閱事件記錄檔和其他的記錄檔資料,以判斷您的系統是否有儲存的相關問題。%n%n其他診斷資訊: %6 %7
�%1 (%2) %3資料庫或記錄檔案的可用空間不足,導致資料庫 '%4' ('%5') 無法正常操作。檢閱資料庫,並記錄磁碟區的可用空間,以識別特定的問題。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3I/O 錯誤導致資料庫 '%4' ('%5') 無法正常操作。檢閱事件記錄檔和其他的記錄檔資料,以判斷您的系統是否有儲存問題。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3被動副本在資料庫 '%4' ('%5') 的裝載副本中偵測到損毀。這項錯誤可能是儲存相關問題的結果。%n%n其他診斷資訊: %6 %7
�%1 (%2) %3已在資料庫 '%4' ('%5') 中偵測到損毀。錯誤可能是由人為錯誤、系統或儲存問題導致。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3資源或作業錯誤導致資料庫 '%4' ('%5') 無法正常操作。檢閱應用程式和系統事件記錄檔,以瞭解資料庫或其所需系統元件的失敗。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3嚴重錯誤導致資料庫 '%4' ('%5') 無法正常操作。檢閱應用程式和系統事件記錄檔,以瞭解資料庫或其所需系統元件的失敗。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3發生問題導致資料庫 '%4' ('%5') 無法正常操作。重新裝載資料庫可能會修正失敗。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3在記錄傳送環境中,被動副本已偵測到讓資料庫 '%4' ('%5') 無法正常操作的錯誤。檢閱應用程式和系統事件記錄檔,以瞭解資料庫或其所需系統元件的失敗。
P%1 (%2) %3嚴重錯誤導致資料庫 '%4' ('%5') 無法正常操作。發生此錯誤的原因可能是電腦設定錯誤,或者有儲存問題或效能問題。請檢閱與資料庫、其儲存區和電腦相關聯的效能計數器和應用程式事件記錄檔,以找出特定的問題。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3異常大量的一般負載導致資料庫 '%4' ('%5') 無法正常操作。應該減少這個資料庫的負載,才能還原適當的作業。
%n
%n其他診斷資訊: %6 %7
�%1 (%2) %3系統發生記憶體配置失敗,導致資料庫 '%4' ('%5') 無法正常操作。電腦的錯誤組態或記憶體耗用過多都可能導致錯誤發生。
%n
%n其他診斷資訊: %6 %7
$CATALOGRESEED_FAILURE_TAG_ID
MAX_FAILURE_TAG_ID
�4VS_VERSION_INFO��
aJ
aJ?�StringFileInfo�040404B0LCompanyNameMicrosoft Corporationj!FileDescriptionMicrosoft(R) Windows(R) �v�S�^8O2QX[_�dh$FileVersion10.0.19041.1 (WinBuild.160101.0800)4
InternalNameesent.dll�.LegalCopyright� Microsoft Corporation. All rights reserved.DOriginalFilenameesent.dll.muij%ProductNameMicrosoft� Windows� Operating System>
ProductVersion10.0.19041.1DVarFileInfo$Translation�PADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADDINGXXPADDINGPADD